User Avatar Image

Jurassic Park: Awful slowdown/chopyness during action on any settings.

posted by Saint Satan on - last edited - Viewed by 300 users

[FIX?] Downloaded the new drivers (1115/11). It seems to have fixed the slowdown slightly, but is still pretty bad.

I have a powerful computer and the games runs like butter until there's action. The game slows down badly and skips around making it near unplayable. It doesn't matter what settings I have on, everything maxed or everything set on low, I get the same exact kind of choppy gameplay during most action scences.

My specs are...

Core i7
HD 5870 Mobility
8GB Ram

Thanks for you're help. It seems like an awesome game so far but this has caused me a few deaths.

15 Comments - Linear Discussion: Classic Style
  • @Michael Parks said: Glad to hear it! Thanks for the update.



    Nevermind. Still getting some bad slowdown, but it doesn't seem to happen quite as much or as bad.

  • The game is streaming data from the hard drive during the action scenes, so the only thing I can think to recommend at the moment is to defrag your hard drive if you haven't done in it a while.

  • I am having same problems, however, it seems to be fixed when setting Graphics Quality to Medium or High. The game is completely unplayable when setting Graphics Quality to Highest.

    This problems is definitely not my hardware or drivers as I normally can play any FPS on high settings with 1900x1200.

    System summary (dxdiag attached):

    Vista 64 with latest SP
    Phenom 9950
    8GB RAM
    Radeon 6770 with latest Catalyst drivers

    Let's help TT fix this so we can enjoy this on the best quality.

    Other than that loving it so far. First episode was very short (even with issues, finished it under 2.5 hours). Overall, great production quality.

  • @Michael Parks said: The game is streaming data from the hard drive during the action scenes, so the only thing I can think to recommend at the moment is to defrag your hard drive if you haven't done in it a while.



    I deragged two days ago.

    :(

  • All of the complaints about this issue seem to be from ATI users. I'm looking into it on my home system right now to try to find a potential fix or workaround, but I don't have a solution just yet. Sorry for the frustration. This will definitely be a priority issue in the office tomorrow.

  • @Michael Parks said: All of the complaints about this issue seem to be from ATI users. I'm looking into it on my home system right now to try to find a potential fix or workaround, but I don't have a solution just yet. Sorry for the frustration. This will definitely be a priority issue in the office tomorrow.


    Yea, I agree...it seems that everyone who has posted (in other threads too) has a HD 5xxx or 6xxx card.

    Let me know if I can help test something out...always happy to do that. (Do note that I have the Steam version.)

  • Out of curiosity, do you guys have Catalyst AI disabled by any chance? Not from the Catalyst Control Center. It's something you would have needed to edit a .xml file to do.

  • I am unable to edit .xml, so unless ATI disabled on its own, it's not disabled here.

  • Any update on this? I also have a Radeon HD 5800 and the game runs terribly. Anytime there is a scene change or rapid action the graphics will freeze for 5-10 seconds at a time.

    I have a Core i7-920, 6GB of ram, and the aforementioned HD 5800.

    I even tried running the game off of my SSD. No improvement. Totally unacceptable.

  • The only fix I've discovered for this is to lower shadows settings, that's the only setting that seems to cause hitchs on my system. Either set it to Low, or turn it off altogether, though the shadows look terrible on Low, so it may just be best to turn them off all together, least till TT decide to fix this.

Add Comment