User Avatar Image

Seriously, did Telltale Games any sort of fixing the last months?

posted by tope1983 on - last edited - Viewed by 320 users

As I was looking forward to this game and actually pre-ordered the deluxe edition I have to say that this game isn't optimized AT ALL!

Reading a lot of posts here I am not the only person having problems.
It seems that Jurassic Park: The Game lacks a lot of optimization, even on PS3!

The game is nearly unplayable at the highest settings, even if your computer easily reaches the recommended specs. Turning on the DOF leads to massive stuttering and lags resulting in desynchronized audio and freezes for more than a whole second. A lot of QTE aren't beatable, scenes are cut or getting repeated.

Especially at the very beginning of Episode 1 there occur some major bugs.
During the Triceratops scene, where Gerry and Jess are overlooking the pen and the player uses the binocular, some dialogues are repeated. This is not a PC only issue. PS3 users are having the same problem.

I completed Episode I and replayed the 2nd scenario of it several times with different settings to find out that the repeated dialogue always occurs.
As this is at the very beginning of the game and TTG wanted to publish this episode already 7 months ago, I am wondering what sort of fixing there has been during the last half year? Any at all?
Or was the game in the april edition even more annoying?

Sorry to say that but especially for a cinematic experience JP:TG isn't polished at all. I feels rushed and sloppy.

41 Comments - Linear Discussion: Classic Style
  • I think the game would be great if i could just play the rest of the damn thing

  • I haven't tried the PC one yet. I'm downloading that one today to see what's up.

  • If this helps you guys out I'm running

    Windows Professional 64 Bit
    Intel i7 920 @ Stock 2.67GHZ
    Nvidia GTX 295 Single Card
    12 GB DDR3 1333mhz Memory

    The only place I have noticed any problems is episode 1 at the start. No problems during the prologue but when you are looking for the Triceritops very slight audio stutter and and when the Dad gets ready to go in the jeep to leave something he says makes it sound like he is a robot. Every time I play it does it in the exact same places. It isn't random. Some of you seem to be having a lot more trouble than I have been. Once past that one seen I haven't seen another glitch or had another problem. Telltale maybe since this setup isn't having as much a problem you can use this as a starting point and see what everyone else is running.

  • Having the same problem, managed to bear it, just enough mind you, to finish the game, but a game shouldn't be running like this, especially one that aims to immerse you. Afterwards, I did some tests and I did note the following, if it's relevant at all, or could be just a shot in the dark and it's only me (posted this in support earlier):

    Interestingly reducing the Shadow quality on the settings significantly reduces the lag (regardless what the other settings are), as a result reducing audio lag and synch issues. Anything higher than Low and it starts getting choppy. General gameplay is fine with all settings maxed out, yet when it comes to QTE and cutscenes it lags periodically as mentioned by others.

    So could it have something to do with the shadows quality? Coincidence? Perhaps.

    Specs:
    Windows XP 32-Bit
    Intel 2.66GHz Q8400 Quad Core
    ATI HD5870 1GB GPU
    4GB (3.5GB - XP lol) DDR2 Ram

  • Finished Installing the PC version. I had to drop down the settings for it to get to a playable level but that's my computers fault and not the games. There were still moments of lag but over all it's running a lot smoother than the PSN version that I have. I need to keep tweeking with the graphics to see if I can get rid of the lag all together. I also need to keep playing to see if I encounter the problem that some are having with not being able to play past episode one.

    So far though, it's running smoother than the PSn version.

  • Seriously needs a patch. I have the audio lag, and screen stutters switching to a new scene. The graphics are okay, just has tech issues. I'm guessing they won't fix them though.

  • @BiscuitDude said: Having the same problem, managed to bear it, just enough mind you, to finish the game, but a game shouldn't be running like this, especially one that aims to immerse you. Afterwards, I did some tests and I did note the following, if it's relevant at all, or could be just a shot in the dark and it's only me (posted this in support earlier):

    Interestingly reducing the Shadow quality on the settings significantly reduces the lag (regardless what the other settings are), as a result reducing audio lag and synch issues. Anything higher than Low and it starts getting choppy. General gameplay is fine with all settings maxed out, yet when it comes to QTE and cutscenes it lags periodically as mentioned by others.

    So could it have something to do with the shadows quality? Coincidence? Perhaps.

    Specs:
    Windows XP 32-Bit
    Intel 2.66GHz Q8400 Quad Core
    ATI HD5870 1GB GPU
    4GB (3.5GB - XP lol) DDR2 Ram


    yes decreased the shadow quality to low and no lagging anymore. I have kept it on the highest graphics settings, as my Rig is more than capable.
    Perhaps it is a problem with the shadows. Can anybody else confirm this?

  • confirmed turning down shadows to low fixed it

  • I played through Episode 1 earlier and apart from the repeating dialogue sequence at the start I haven't suffered any problems and I am running everything at max at 1920x1080

  • I have to say I agree with the optimization complaints, I purchased the game on PS3 and for the graphics quality of the game it lags like crazy, so PC players, its not just you. To hear the same problems are occuring on PC as well shows indication of a more serious issue than "turning down graphics options".

    Being the first Telltale game I have purchased I have to say I'm disappointed. Basic optimization is something that people expect, for the game to run smoothly at whatever settings their particular system can handle is something people expect.

    I just hope they get patches out quickly to address this issue since I want to be able to enjoy the game and not have it lagging.

Add Comment