User Avatar Image

Common JP Problems/Solutions

posted by TonsOfChocobo on - last edited - Viewed by 6K users

Let's consolidate solutions to common problems mentioned here so far. Add more fixes if you know of any.

-Frame Rate is lagging
In the graphics settings, lower the Shadow quality to Low and/or turn off the DoF option. This appears to be a graphics card issue on certain ATI cards.

-Mouse pointer randomly goes missing during Exploration sequences
Close the game and reopen it.

-Game goes back to main menu after completing a scenario
The game will only progress during a Load playthough. If you are playing using the Scenario option, the game will reset to the menu after completion, as was intended.

-Game won't start up again after exiting.
Open the Task Manager and look for the game in the Processes tab. Select it and hit End Process. Try starting game again.

-Certain Achievements not activating
Some achievements must be obtained through a Load playthrough and won't activate if playing on Scenario.

70 Comments - Linear Discussion: Classic Style
  • just curious if anyone had an idea on when they might be fixing these issues cause they do get kinda annoying xD

  • @TonsOfChocobo said: -Game goes back to main menu after completing a scenario
    The game will only progress while playing with the Load option in the main menu. If you are playing using the Scenario option, the game will reset to the menu after completion as intended.

    Yeah, it took me a while to figure that one out. Maybe they should have included a readme or sort of manual since the game is not as self explaining as the previus TTG.

  • User Avatar Image
    Ben Telltale Staff

    Thanks for collecting these. Worth being sticky I think.

  • i did complet the game and i have lag that is annoying for me it is all the time some times it happed when you need to press on the game pad and sometimes its happed when you dont need to press at all.

  • When I finished an episode, there never showed up any credits.
    It just continued with the next episode.
    Any comment on that?

  • @tope1983 said: When I finished an episode, there never showed up any credits.
    It just continued with the next episode.
    Any comment on that?

    I think they deleted the single credits after they decided to build one big game consisting out of several Episodes. I would have appreciated it to see the single credits, too.

  • @tope1983 said: When I finished an episode, there never showed up any credits.
    It just continued with the next episode.
    Any comment on that?

    It was by design that the credits only play at the end of Episode 4.

  • I'm getting the disappearing mouse pointer issue. Crap.

  • I'm on a Mac running OS 10.7 and the game was running fine. I closed out, and now when I reopen the game, the screen goes black. The audio still plays and it I move the mouse I can hear it moving over the menu, but the screen stays black.

  • So I have a pretty killer system yet I'm having issues.

    The frame rate is super fast, but the game seems to stick on a frame for 1-2 seconds while music and sound continues. It's definitely not a frame rate issue as I have reduced everything and found the same issue at any setting. It's almost similar to what happens when your streaming a video online and it hasn't buffered enough.

    Really annoying, especially when the game is made up of important button mashing moments.

    Here are my stats:
    i7 3.2GHz, 12 GB DDR3 RAM, 1GB ATI Radeon HD5870. I should not be experiencing these issues. Can a member from the team comment on this? Thanks.

    Just to note this issue makes the game unplayable in my opinion as it becomes frustrating beyond belief.

Add Comment