Menu
User Avatar Image

Jurassic Park game-breaking bug

posted by lordvader900 on - last edited - Viewed by 1.1K users

Hey, everyone.

I just downloaded Jurassic Park and I am stuck at the scene in Episode 1 where the Tyrannosaurus and Triceratops are preparing to fight and Harding has to climb out from under the fence. I push the first action button (RB + right stick up) and nothing happens, and the tyrannosaur proceeds to crush me underfoot. I am playing on PC with a 360 controller, and switching over to mouse control does nothing either. So is this a bug or am I doing something wrong? If I am doing something wrong, please don't say what I'm missing.

By the way, amazing game so far!

FIX: Look a bit below!

20 Comments - Linear Discussion: Classic Style
  • If you are playing on pc, try to low the graphics in the menu and see if it helps with the timing issue for QTE.

  • Ok, not sure if this is a bug, but I'm putting the Bone Shaker's carts together in the order it says, and nothing is happening

  • It seems like both nimmzewi and I are experienceing the same bug - hitting B (or whatever arrow key) continueously and nothing is happeneing. This must be a bug, because restarting the scenario does nothing either.

    Well, I'll be trying again tonight. We'll see if it works after a restart. If not, I'm going to try that latest ATI driver patch and see if it helps. Could someone please put a link to it for a Radeon 5500 HD?

    Oh, and from what FankyMaloon says, that is a solution, but shouldn't you only have to push the buttons once? I mean, it doesn't ever tell you to push the buttons repeadeadly by showing a pulsing button icon on-screen, so shouldn't that be a bug too? I think we need a patch already, unless it's just the people here.

  • Just an update, I reset it and it works fine :-)

  • I figured out the fix, for anyone having the same problem!

    You have to set the "graphics quality" to high, not Very High. Then you must restart the entire episode - no joke. You lose the DoF effect and a bit of shading, but it fixes the glitch. And that's better than not playing at all, isn't it? (In fact, the game was so good I didn't mind playing it again.)

  • I'm having both of these problems in this sequence as well. Picked up JP in the Steam sale despite hearing a lot of negative word of mouth because I'm a fan of Telltale's stuff. This is really souring me though. I'm not going to play through the whole episode again with lowered graphics just to get to this point.

    Wasn't this the sequence you guys showed off during the PR cycle? How did this get through press demos? Seriously? This needs a patch desperately.

  • Still nothing from Telltale? This is clearly reproducible if we have this many people getting the error. Let us know if you need system specs, dxdiags or save games or whatever. But you really do need to address this.

  • i'm here to tell you this bug is still alive and well in the spring of 2015 and it's still a game breaker.

    i'm done with this one, dead under the gate.

  • I hate to tell you people this but it isn't a bug and never was. If the game isn't registering what you are doing it has to do with the graphics detail. If the computer feels there is too much going on its gonna be slow on the uptake of registering keystrokes or button pressing. I've died plenty of times playing the game but I've also beaten three times. It's not broken. It's tedious yes. Annoying yes at times. But not broken. Someone said they were having the issue and lowed the graphics setting and it fixed the problem they were having. Telltale isn't responding simply because it's not a bug.

  • You choosing to not want to play through the whole episode again on a lowered graphics setting because your computer apparently is having issues at least partially playing it on the best, is not telltales fault. The only way it would be their fault is if they only had one graphics setting and they don't.

Add Comment