User Avatar Image

[WD] Can't Play EP2 on PlayStation [RESOLVED - restart the game]

posted by American398 on - last edited - Viewed by 5.4K users

Hey guys, i have downloaded Episode 2 from the playstation store and installed it. when i got to play it, it sends me back to the main ps3 screen, i have seen other players have this issue also, any fix?

527 Comments - Linear Discussion: Classic Style
  • @fackyoutelltale said: greenboy try downloading the demo if you haven't already. if that doesn't worked then i think your fucked.

    i don't think the problem is the demo i just could not find it in the psn store or having an update on the game itself.....i guess am turning blue after my next hour of sorrow.....

  • Am I the only one that finds it upsetting that it took only 10 min for people to start calling the developers a$$h@les and start freaking out because they didn't have an update already? It's not like the developers are actually the ones moderating the forumns they have better things to do. As a product manager in software development the entitlement on here just blows my mind. I'm at work right now and was really looking forward to starting episode 2 tonight. I'll be really bummed if it doesn't work but I'm not going to start spewing hate at the developers! you wouldn't even have this amazing game if it wasn't for them and I'm sure this isn't an intentional mistake. For all you know someone at sony could have mixed up the release code and posted an older version with known issues. The only thing you can do at this point is try to provide TellTale and Sony with as much information as you can about the exact situation you are in so that they can accurately try to recreate the problem and troubleshoot it.

    I understand how much time can sometimes go into troubleshooting an issue. I have a slim and Fat PS3 at home one with an original HDD and one that I just recently upgraded. I will try the game on both tonight one downloaded in game and one from the store and I will update with what occurs in both instances.


    TellTale,
    From all of us that are still sane please take your time and fix the problem fully and don't rush out a patch that may also have issues. Thank you so much for creating a wonderful experience with episode 1 I enjoyed it fully and look forward to diving into episode 2 head first once it's working properly.

  • @RancidYeti said: Hey everyone! Here's your brand new car you paid for months ago! Except there's no keys. Or tires. Or an engine. Or a body. Can't you see it? We took your money and worked really hard to get it to you late, so here it is! We hope you enjoy not driving your invisible car! We're working on your invisible boat for next month so keep waiting everyone! Thanks (suckers)!
    -Just to put things into perspective Telltale. Thank you very little for a whole lot of nothing.


    And people really wonder why they aren't constantly on here talking with us? Goofs like this ruin it for the rest of us with hyperbole. Especially when the problem is already fixed. You'd be the person to call customer support and by the end of the call, before the employee either hung up on you for being rude or transferred you to someone else, would have threatened the persons unborn kids.

  • I digress. Thank you very much for that little patch! "Ive had a bad day and I f^@#in hate the Eagles man.." -The Dude

  • @Backlace said: I love how all the people previously bitching and moaning have now spun on a fucking dime and are praising the devs like none other.

    Regardless, I'm glad this was resolved quickly, and thank you for your efforts, Telltale.


    Predictable really. Sheeple usually are.

  • Well excuse me for a little sarcasm to lighten the mood and put things into perspective Mr. Serious. You Sir, may piss into thee wind. Goodday.

  • Anyone know of any other games that are broken and waiting for a fix? I'm bored again and this topic seems to have gone cold.

  • @Syllius said: Anyone know of any other games that are broken and waiting for a fix? I'm bored again and this topic seems to have gone cold.

    Nice :)

  • People of the world, apart from shitty EU... damn you lucky bastards.

  • @Mike said: Sony just pushed an update and I was able to confirm that Episode 2 is launching just fine now. You'll need to restart the game, but it will prompt you to download version 1.01 automatically. Please let us know if you're still having any issue with it.

    Thank you so much for your patience with this!

    I concur it is now running, loaded a little slow so I thought it was going to kick me out and then it started running. thanks for the prompt patch of the glitch

Add Comment