User Avatar Image

Stuck at "connecting"

posted by meiwow on - last edited - Viewed by 502 users

I boot up the game (steam pc version) and when I get to the main screen that says "click to continue", I do so and the game remains stuck on "connecting" for an eternity and it doesn't go through... I've tried this multiple times already... Help?
I HATE games that require constant BS verification...!
What is it "connecting" to anyway??? SO frustrating!
What happened to the days when you didn't have to connect to anything to play your damn frikging game!?
I though I could just relax and play this game after a hard day's work but... NOOOO silly me! What was I thinking!?
I'm going to stop buying stuff on steam if this crap continues....

13 Comments - Linear Discussion: Classic Style
  • I am having same problem..I played earlier today with no problems...waiting for help. let me know if anyone has luck

  • I'm also having this problem. Hopefully it's temporary.

  • really wanted to kick back and game tonight.. guess not.

  • It let me in after long godamn LAST!!!!!!!!!!!!! christ!!

  • Same problem here too. If it ain't one thing it is another with this company. This is really pathetic.

  • Same issue. I start the game, it's stuck on connecting. I have tried many troubleshooting techniques found all over the internet to try and resolve it, I can not.

    I purchased the game on Steam earlier this morning and I have been waiting all day for it to download. I didn't realise that if I was playing another steam game, the download would be paused... so that was annoying to find out it was on pause, 4 hours after patiently waiting for it to download.

    Why is it connecting out at the login screen? It should be coded to be playable even if there is some server down somewhere, or another reason behind a connecting requirement.

    Can someone please confirm if there is a server down. I will be applying for my money back if this isn't resolved soon. The number of hits I found on google for this error is astounding.

  • With 225 views of this post in 30 minutes or so, I would say we are not the only ones with this problem? =)

  • While I was searching for a solution i may have found one from back when Episode 1 came out:

    Note: I have this on steam so I closed steam first then opened it back up after doing what it said below and it seems to have worked.

    ---------------------
    From corruptbiggins:
    I was having this problem, I fixed it by making the game executable run as an administrator in privilege level. Here's how to do it:

    Find the file WalkingDead101.exe either by searching for it or going to your steam folder (usually Program Files->Steam), then going to steamapps->common->the walking dead. Once the file has been found, right click and choose properties then select the compatibility tab. At the bottom under privilege level check the box that says 'Run this program as an administrator'.

    This is what I did and the next time I tried to run the game it connected in seconds.
    ------------------------

  • I'm still getting this issue. I didn't get this issue at all with Episode 1, everything was perfect. I downloaded Episode 2 last night, so I could play today, and I've been trying to access the game all day without any luck, so am very frustrated. I'm using the Telltale exe, not Steam.

    Is there a server issue? I'm based in England so is this a local issue?

  • i still can't get the telltale version of ep 2 to download sell get disconnected between 70% and 85% I'm using a mac all my stuff is up to date this is very frustrating and getting to the point of it all being more trouble than its worth

Add Comment