User Avatar Image

Glitch At Trainstation Zombie-Fight Part Thingy

posted by FladeIsCool on - last edited - Viewed by 4.1K users

I got to what I believe to be near the end of Episode 3, where you go into the train station and zombies attack you. When you're trying to walk back away from them, I mouse over and press the wrench when I'm close enough, and it just looks at it and I die. When I tried modifying how I interacted with it, it wouldn't even work. I'm not sure if I'm doing it wrong or it's a glitch, but it's keeping me from continuing the game. I need help.

16 Comments - Linear Discussion: Classic Style
  • OK OK OK I was frustrated and upset and I was doing it wrong, but I figured it out. This may help some of you who are stuck so here is what I was doing wrong and I feel stupid about it.

    There is a tip that says to press W to back away from the zombies. I thought I was doing this. One time I randomly looked down at the keyboard and realized that I had been pressing S which came naturally to me because S is the button you press to move backwards in 99% of PC games. Not this game, in this scene. As soon as you have control over Lee hold down the W key to back away NOT THE S KEY! Goodbye.

  • @ArthurV said: Try hitting the "2" key on the keyboard first before clicking on the wrench. Your mouse scroll wheel will also work.

    Thanks, this was the fix. As long as you're holding W (or your back key) the entire time without punching the zombies, you'll get there quick enough.

  • Yeah. I'm stuck too.

    I tried twice to catch the wrench but Lee doesn't catch, just look it.

  • User Avatar Image
    ArthurV Telltale Staff

    @John Schutze said: Yeah. I'm stuck too.

    I tried twice to catch the wrench but Lee doesn't catch, just look it.

    To grab the wrench:
    1) Back up away from the two zombies by holding the "W" key. Don't bother punching them.
    2) When in range of the wrench, cursor over it.
    3) Two options: Scroll your mouse wheel up or hit "2" on your keyboard.
    4) Click on the wrench.
    5) Bash zombie skulls.

  • There are 2 actions on the wrench(examine and take). Not a glitch.
    But I don't like the action aiming system where you have to hit the little circle on the zombie... it's really hard to click the dot when the zombies are moving(need to stay on the dot for like 100ms for the action box to show up..)

  • Yeah, I died about two times and realized I had to select the Wrench. Didn't "feel" right considering I was backing up. Feedback for developers, I think. It wasn't bad on the PS3 as it's expected to hit one of the appropriate action buttons. Yes this mechanic has been on the PC since EP1 but I can understand the frustration of others on this one.

  • I'm on a PC and was making the mistake of repeating "W" to back away.
    Simply HOLD down the W key to back away... you'll have plenty of time
    to select the wrench.
    "Thank You" to everyone on this thread, I almost gave up on this game.

  • Aaaaah! Thank you, Arthur. I was going crazy. If you heard a strange rumbling off in the distance that was me, repeatedly yelling "PICK THE @*#&!! THING UP, LEE!" :)

  • Same issue, first time I didn't notice I could back away.

    First time: I was too busy looking at the zombies and trying to click the wrench while avoiding clicking the zombie as it wiggled it's head over the point I was trying to click... I clicked zombie instead of wrench, punched it and died.

    Second time, noticed the message a bit too late and died again.

    3rd onwards. Walked right up to the wrench, clicked it, looked at it... OOOW WRENCH! died.

    Eventually told the zombies and the long cut scene you have to sit through per death to go fornicate with it's self and looked up if others had similar issues.

    The fact you need to press 2 or scroll is probably the ONLY time in the game thus far that a multi interactable object has it's opens layed out around the cursor rather than decending from it in a list. Very unintuative.

    I'm not even sure why you decided to give players the option to look at the wrench, it's a death sentence every time you click on it and it's NEVER been what I wanted to do with it, I'm sure that goes for every other player that has or will play the game.

    Not fun.

    P.S. Awesome game in general, but there are a few too many little things like this that suck the enjoyment out of the gaming session, I do hope 4 and 5 go a bit smoother and challenge the player rather than just frustrate/change the rules.

    At least I've got coffee and Chapter 4 still to go!

    Now to go wrench some zombies...


  • lol im so glad i play this on an xbox cause this game sounds frustrating as fuck on the pc

Add Comment