User Avatar Image

Connection lost while downloading?

posted by buntah on - last edited - Viewed by 857 users

I'm trying to download Episode 4 and I keep getting a message telling me the connection was lost while downloading ... but I'm only at 0% ... and obviously my internet connection is working fine cuz I'm here! Is there a problem on Telltale's end that I don't know about?

49 Comments - Linear Discussion: Classic Style
  • I'm having the same problem.

  • Having the same problem. It gets to about 70%, freezes, gives me that message, and then goes to 60%. This has been happening for about 2 hours now. It one time got to 99% before freezing.

  • @Gman5852 said: Having the same problem. It gets to about 70%, freezes, gives me that message, and then goes to 60%. This has been happening for about 2 hours now. It one time got to 99% before freezing.



    I wouldn't be so irritated if I could even get that much. I'll click Get and immediately at 0.0%, it tells me I have no connection. Never mind the fact that it already checked the connection once before even letting me into the menu screen.

    It's really disappointing, especially since there hasn't been a word of support on the topic.

  • Well, that didn't work for me. Now the game opens in Window mode and asks me for my user name and password to unlock the game (like the first time I played Episode 1) and when I enter the info, the games locks up and doesn't go any further *sigh*

  • @buntah said: Well, that didn't work for me. Now the game opens in Window mode and asks me for my user name and password to unlock the game (like the first time I played Episode 1) and when I enter the info, the games locks up and doesn't go any further *sigh*



    Which did you try specifically? I'm going to try manual downloading it the moment this fails again.

  • I downloaded all of the episode 4 files and put them in the folder ... didn't work for me. But, I removed all the files and opened the game to try it from there again and now the "get" button isn't there ... now it says "coming soon" so I'm thinking maybe TTG has pulled the episode until they fix the bugs.

  • @buntah said: I downloaded all of the episode 4 files and put them in the folder ... didn't work for me. But, I removed all the files and opened the game to try it from there again and now the "get" button isn't there ... now it says "coming soon" so I'm thinking maybe TTG has pulled the episode until they fix the bugs.



    It's still there for me. It doesn't work, but it's there.

    And I just have to say, Telltale, I love this game, and I love this company, but for the love of god this is the worst downloading process I have EVER been through. I find it hard to believe you guys NEVER caught these issues when testing this, when it's happened to every single person I talk to about this game with, and it has effected them every single episode. Absolutely pathetic.

  • Connection lost while downloading... I get this message the moment the download starts

  • Getting this now. I've gone up from "your account does not have this game liscence" (which I did, I bought the game) to "internet connection error". :/ Even if it downloads, maybe I'll just wait to ep 5 is out...

Add Comment