User Avatar Image

Connection lost while downloading?

posted by buntah on - last edited - Viewed by 1.8K users

I'm trying to download Episode 4 and I keep getting a message telling me the connection was lost while downloading ... but I'm only at 0% ... and obviously my internet connection is working fine cuz I'm here! Is there a problem on Telltale's end that I don't know about?

49 Comments - Linear Discussion: Classic Style
  • I have the same problem, my internet connection is fine, and the download still gives me the same message at around 30% "download Connection lost while downloading data. Please ensure you have a working internet connection and re-attempt download."
    I too have never had any problems downloading the first 3 chapters. Please fix this Telltale, because we are clearly many frustratet fans at the moment.

    Later...well now suddently it gives me the aforementioned message instantly when It reaches 10% download. Please help!

    Kind regards

  • "Small number". Such utter bullshit. I think there's a problem with their servers personally.

  • Add me to the long list of paying customers that cannot download Episode 4 due to the connection issue.

    Telltale Games: Please acknowledge the problem, post something somewhere to assure us that it is being addressed, or better yet, fix the problem. My confidence in your company has declined substantially! I have been a gamer for a long, long time and never seen a company treat such a major issue with such silence.

    Very disappointing!

  • Has anyone found a solution to this yet?! I have e-mail Telltale - NO RESPONSE -and have paid for all of these episodes in advance! Yet I'm having the same problem - download Connection lost! I've tried connecting to a different Wifi Network, I've tried rebooting my modem, nothing! This is so frustrating! I love Telltale's Games, but their service is Rubbish! Surely, as a group of paying customers, there must be something we can do here?!

  • Same problem here. Actually I can't download Ep 3 either. And I don't even get as far as some of you; it flashes 0.0% and then immediately displays the error. I've had this problem since Tues.

    My internet connection is fine, and I had no problems downloading the first two episodes prior to that.

    I'm pretty sure this is due to their servers being clogged with people trying to d/l Ep 4, and I understand that these things happen. TTG employees are just human beings who do work their arses off to provide us with great games and at the end of the day they go home to their families. But for the love of god TTG, at least acknowledge the issue! Are you just waiting for this to "blow over" or something?

  • Maybe we (the customers) can help out here. Could there be something specific about our internet providers that might cause this issue? Something we all have in common?

    I'm logging in from Calgary Alberta (Canada) and my internet provider is Shaw. I'm on a wired connection. Anyone else?

  • I had a similar problem: my download failed at 0%. However, the manual workaround posted earlier worked for me.

  • The manual workaround didn't work for me. I went through all of the steps, and then on the 2nd-to-last step where I have to click "get" again, it still displays the connection failure. Baffling! Especially the fact that apparently, my connection problems cannot be fixed by the same workaround that appears to have worked for everyone else.

  • has anyone had any luck yet or a reply from telltale with more information?

Add Comment