User Avatar Image

TWD: Regarding Xbox gamepads, WalkingDead101.exe errors, download issues and saves

posted by HungryHippo5 on - last edited - Viewed by 332 users

This may already be common knowledge, but I figured I'd post my own findings after having some of my own issues and getting them fixed.

I was one of the players that encountered the whole unable to download Episode 4 error, which was then given an unofficial fix thanks to DjNDB. After using his method to download the Ep. 4 files via Python script, I hooked up my Xbox gamepad and sat down to finally enjoy...only to then discover that the app wouldn't even start this time.

After a week and a bit of scratching my head trying to figure out why it wouldn't start, I finally cracked it. I believe it's all to do with the prefs.prop file in the My Documents\Telltale Games\The Walking Dead folder (on PC, I would assume in the Mac equivalent as well).

After having to remove my Xbox pad to free up my USB port, I tried running the application and strangely enough, it worked, though I noticed it was windowed and my settings were all gone. Having gone through the process of uninstalling and re-installing multiple times, I downloaded Episodes 2-4 using DjNDB's script as in-game download still wouldn't work, and copied them as per the instructions. Copying in my backed-up save data, I checked to see my game file would work, and sure enough it did.

Out of curiosity, I decided to re-back up all my data and try plugging in my Xbox gamepad again to see what would happen, and as expected, the game didn't launch. After removing it, not only did my preferences revert to default, I had to re-authenticate, and none of my save files were detected despite being located in the folder.

I then realised that the file size of prefs.prop was 9k, the same size after the fresh install, not the 69k when I copied it into the directory along with my save game. I copied my old prefs.prop file back in and all my saves were detected again and worked fine.

From this, I think we can assume that not only does the prefs.prop file contain your game preferences such as display resolution, but also contains data regarding use of gamepad as input as well as data linked to reading the player's save data. I'm guessing that plugging in the Xbox gamepad then starting the game appears to somehow prevent the game from reading the prefs.prop file, corrupting it at the same time. Restarting the game afterwards then realises the file is corrupt, so reverts to default and then in doing so deletes system preferences, authentication data and whatever is required to link to your save games. N.B. that this did not have an impact on the installed episode data, which was still intact.

So, basically, to summarise:
[*]Make sure you copy your prefs.prop file when backing up your save data!
[*]If your game cannot read your save data, try reverting your prefs.prop file to your backed-up version.
[*]If you're getting a 101.exe crash whilst attempting to play with an Xbox gamepad or similar peripheral plugged in, try removing it.

Like I said, this may be common knowledge already, but I'm hoping this will maybe help someone who's had the same problems I've had, and that maybe someone at Telltale will read this and be able to fix the issue if they haven't already.

1 Comment - Linear Discussion: Classic Style
  • I've got the same issue going on. When my X360 wireless gamepad is connected the game will not run for some reason.

    This seems to have started only after Episode 3 was released. Up until this point I had always played with my gamepad. It's frustrating that it's suddenly not working now.

    Telltale, please help resolve this issue! Episode 4 is out and I still haven't played the game since the game won't work!

    I can technically play with mouse and keyboard but since the PC I play it on is hooked up to the TV, it's a bit of a drag to get my mouse and KB all the way to the living room and then find space for them.

Add Comment