User Avatar Image

[TWD] Audio Issues (STEAM)

posted by Drakosmick on - last edited - Viewed by 1.3K users

Hi everyone, I'm here to present you a problem that I have with TWD original game on Steam.
Every 5 minutes (especially in crowded areas) the game freeze for 5 second to render and it is normal but it also present a strange audio lag like "trrrrrrr" or similar...
I CAN'T SOLVE THIS PROBLEM, HELP PLEASE.
:)

47 Comments - Linear Discussion: Classic Style
  • There can be something in the fact i've changed visive effects in the OS from panel control?

  • User Avatar Image
    DjNDB Moderator

    I have no lead what causes it yet, so anything is possible.

    Logging some data while you run the game might help finding the cause.

    These tools will log your CPU and GPU activity.

    CPU: Download Core Temp. Start it and activate logging in the menu under "Tools/Logging on".

    The log file created is called similar to "CT-Log [TIME][DATE].csv".

    GPU: Download GPU-Z.
    Start it, select the "sensors" tab, and activate "Log to File" at the bottom of the window.
    Choose a location for the log file.

    Now run the game for a few minutes until it has stuttered at least 2-3 times.

    Finally Zip the files and attach them to a reply in this Thread.

  • Here, man.
    [ATTACH]3512[/ATTACH]
    ;)

  • User Avatar Image
    DjNDB Moderator

    There's some interesting information in there.

    In the CPU log there is 100% load at 20:59:30 11/16/12 for about 30 seconds. That might just be the game starting up, but i can't be sure.

    The GPU log shows something promising though.
    At 2012-11-16 21:01:23 and 2012-11-16 21:01:57 the GPU load is 100% for 1-2 seconds each time.
    That's about 34 seconds apart, very close to the distance of the two major glitches in your video.

    It is also visible that your graphics card clocks down from 800 MHz to 100 MHz just before that happens.

    That means, if there's a setting in your catalyst control center, that disables the power saving features of your graphics card, so that it doesn't slow down when the load is low, there's a good chance you can get rid of the glitches.

    That's actually similar to what we tried earlier, but that power saving setting didn't include the graphics card.

  • I'm having the exact same problem right now. I'm pretty sure running it in compatibility windows 98/me mode is causing this problem for me but I need to run it in this mode to prevent it from crashing and losing my save file.

    This is so absurd, I can either keep launching the game hoping it doesn't crash, play through an entire episode in one sitting, and when I next start the game it will probably crash and loss my save so I'll just have to play each episode with random choices but there will be no stuttering OR

    I can fix the crash and keep my save file through each episode BUT there will be constant stuttering during any action scene. I've enjoyed the game up to this point but the problems are becoming to much for me.

  • @DjNDB said: There's some interesting information in there.

    In the CPU log there is 100% load at 20:59:30 11/16/12 for about 30 seconds. That might just be the game starting up, but i can't be sure.

    The GPU log shows something promising though.
    At 2012-11-16 21:01:23 and 2012-11-16 21:01:57 the GPU load is 100% for 1-2 seconds each time.
    That's about 34 seconds apart, very close to the distance of the two major glitches in your video.

    It is also visible that your graphics card clocks down from 800 MHz to 100 MHz just before that happens.

    That means, if there's a setting in your catalyst control center, that disables the power saving features of your graphics card, so that it doesn't slow down when the load is low, there's a good chance you can get rid of the glitches.

    That's actually similar to what we tried earlier, but that power saving setting didn't include the graphics card.

    I can't find any power saving setting in AMD Vision Engine Control Center, I have the 12.10 version if that might help...

  • User Avatar Image
    DjNDB Moderator

    @Drakosmick said: I can't find any power saving setting in AMD Vision Engine Control Center, I have the 12.10 version if that might help...

    I don't have the same card, so i can't really help finding the setting.
    From what i have found out the feature to disable is called AMD PowerPlay.

    It might not be possible in the AMD settings though.
    Some search suggested that it can be disabled using MSI Afterburner by editing the config file.

    Be aware that using tools like that involves a risk, so only use them if you know what you are doing and how to recover from problems that could occur.

  • User Avatar Image
    DjNDB Moderator

    Disabling AMD PowerPlay was the most promising workaround i found that should have helped.
    Please make sure that the values in the MSIAfterburner.cfg are exactly like this:

    UnofficialOverclockingEULA = I confirm that I am aware of unofficial overclocking limitations and fully understand that MSI will not provide me any support on it
    UnofficialOverclockingMode = 2

    Then try the game again.

    If it still stutters, please check if the GPU clocks down just before the game stutters.

    To do that you can enable the On Screen Display of MSI Afterburner and watch the values while you run the game.
    In order to do that open MSI Afterburner, click on "settings" and open the "Monitoring" tab.

    Look at the middle section called "Active hardware monitoring graphs".
    Select "Core clock" and check the "Show in On-Screen display" box at the bottom.
    Do the same for "GPU usage".

    The game should now show two values.
    twdosd.png

    The first value shows the GPU load, the second one the GPU clock.

    Now try disabling PowerPlay again using the MSI Afterburner config, and run the game.
    If the GPU clock is low for a while, and than jumps to a higher value, while the game stutters, PowerPlay is still enabled.

    If you are not sure how to interpret the values, you can make another video to show me the result.

Add Comment