User Avatar Image

"Storage device lost"

posted by Luizao876 on - last edited - Viewed by 12.4K users

For some reason, everytime I play Episode 5, and when it is on loading, this pops on:

"The storage device was removed while saving or loading. The game will now exit to the title screen."

Then, when I restart to where I was, it never loads, it stays in a black screen and never loads.

Does Telltale or someone knows the solution for this?

157 Comments - Linear Discussion: Classic Style
  • Well we are now in a New Year and so I hope that Telltale can get working on this issue.

  • I bought episodes 1-4 on a different account that I bought episode 5 on. I get to chapter 4 and then it gives storage device lost, Telltale fix this. I would really like to get what I payed for and by the looks of it your taking ya'll sweet time resolving this issue. All in all it has been a great game so far I personally love it and would love it even more if I got to play it. P.S Happy New Year

  • I wouldn't mind so much if Telltale were open about what is going on. Instead they have retreated to the shadows in the hope this will all go away

  • Hello we have 2013, i've got the game on winter sale on xbox live. First two episedes runned well, but third and fourth show this strange error of device has ben removed as described over here. I have xbox slim arcade (4gb) version any news on this?!?! 600 MS points is not a lot but i feel a bit bad to be robbed...

  • What's annoying me is how quickly they have responded to the problems with the disc based version of the game. They're offering a free download version to those who bought it.

    Now of course I don't begrudge them getting this and being able to play the game but what about the digital customers?

    All we've gotten are two updates that have fixed nothing.

    I'm unable to play the game because of the "Storage Device Lost" error, just like the disc based people couldn't because of the stuttering. How about Telltale give a few words of comfort at the very least.

  • I don't hold out much hope but maybe the new patch will fix this.

  • @voteDC said: I wouldn't mind so much if Telltale were open about what is going on. Instead they have retreated to the shadows in the hope this will all go away

    They're more worried about making Walking Dead Season 2 then fixing these problems.

  • I am also having this problem. I get to The Gauntlet in Episode 5 and then this error pops up. It's strange, because I've been able to complete the game twice previously and had nothing of the sort happen.

  • @HarshMouse said: I think it would help our situation if everyone who has this problem would speak up instead of just lurking this thread and hoping this gets solved.

    Yes, I know you're out there! Speak up! :D

    You're right. I started having this problem once I started a new game on slot 3. I guess three is the magic number because it never happened before that. I really hope Telltale fixes this.

  • Anyone tried playing recently to see if they've fixed this?

    I know I should try but I can bring myself to start playing only to be kicked out of the game again.

Add Comment