User Avatar Image

TWD crash on connecting

posted by halldorr on - last edited - Viewed by 4K users

Picked up a copy of TWD for my wife on Steam as I loved the game but she just can't play the damn thing. We have identical computers as far as hardware goes and it ran just fine for me.

Here are the things we've pulled from the forums and tried so far:

1) Played with compatibility sittings, tried them all but no luck
2) Set run as administrator, no luck, set to all users, no luck
3) Tried replacing a DLL here and there as suggested, no luck
4) We don't have controllers but we pulled all USB stuff one by one, no luck
5) Disable internet connection - this appeared to work

Is there a fix to this? I'd like her to be able to play as the game intended and have the Steam sync work properly for her without having to always disabling her internet connection.

We're both on Windows 7 64bit and we connect tot he web through a home router. Seems odd that it would crash on connecting but that is where we seem to have an issue every time.

151 Comments - Linear Discussion: Classic Style
  • Done and done.

    This is the file i got:
    File

    I understand nothing in this log file XD so yeah.

    Also a bit shout out and thanks to you man! Being a volunteer and to know so much as well as willing to help! You are just too awesome! Thanks a ton

  • User Avatar Image
    DjNDB Moderator

    Thanks for the appreciation.

    The download link doesn't work. It doesn't look like the normal ge.tt download links too, so you might have copied the wrong link. After fixing the link, it says "This file is not available, because the upload was interrupted."

    Please check if you can download the file yourself.

    If not, please try uploading it again.
    There's a "copy link" button at the top after the download, to get the correct link.

  • Whoops, sorry my bad -.-

    I didn't let it upload completely. Hehe, it looked weird to me as well. Now i do see the process bar on the left. Just usually they give a "Download" button only AFTER the file is uploaded XD

    Anyhow here is the right link

  • User Avatar Image
    DjNDB Moderator

    Yeah, I'm gonna need some time analyzing that :-D

    The game did crash right before you stopped logging, right?

    Have you already tried disabling the Steam Overlay for TWD?
    Right click on TWD, click on "Properties" and uncheck "Enable Steam Community In-Game" in the "General" tab.

  • I made sure the process was terminated and no more enteries went to that window. And i believe that steam has nothing to do with it. I checked anyway and it still crashes. I think it has something to do with the fact there is an internet connection, though i am not experienced enough to know why.

  • User Avatar Image
    DjNDB Moderator

    I am still trying to figure out something with the process monitor.

    Can you see anything unusual in the Steam log files?

    It might also be useful if you did another process monitor log, running the game error free, with the network disabled.
    That way i could compare them, instead of trying to compare it with a log from my system.

  • Unfortunately i have no idea even where to read them, or how to.

    Too bad you are at it all alone =( and it begins to be really late for me now, have work tomorrow morning.

    Is there anything i can do? Where i can find the log at least? (I am very new to steam, as i never used it before few month ago)

  • User Avatar Image
    DjNDB Moderator

    @perilomo said:
    Description: Speakers (Rapoo Wireless Audio)
    Date and Size: 7/14/2009 02:06:32, 109568 bytes

    Description: Realtek Digital Output (Realtek High Definition Audio)
    Date and Size: 8/25/2009 13:28:08, 1990304 bytes

    I just had an unusual thought, because it doesn't make much sense, but i've seen strange things before.

    Please update your Realtek HDA driver
    and unplug all non essential USB devices. That means also means that Rapoo Wireless Audio device with the old drivers.

  • This is my only headset. I have no other sound sources. Gonna try it regardless, but it still doesn't explain how the game runs with the same hardware and drivers while without internet.

    Gonna do so now.

  • User Avatar Image
    DjNDB Moderator

    @perilomo said: Unfortunately i have no idea even where to read them, or how to.

    Too bad you are at it all alone =( and it begins to be really late for me now, have work tomorrow morning.

    Is there anything i can do? Where i can find the log at least? (I am very new to steam, as i never used it before few month ago)

    Don't worry, I'll be here tomorrow. Have a good night.

    For tomorrow:
    Did you see my edit about the second process monitor run?

    Also there are some *.log files in the Steam folder, and some files in Steam\logs.
    I have no experience with them, but I would take a look at them.

    @perilomo said: This is my only headset. I have no other sound sources. Gonna try it regardless, but it still doesn't explain how the game runs with the same hardware and drivers while without internet.

    Gonna do so now.

    That's what i meant by it doesn't make sense.
    But i know that the game has issues with old Realtek HDA drivers, at least if the sound device is used.
    Knowing no fix, it's worth trying to optimize everything.

    P.S. I order you to go to bed :-P

Add Comment