User Avatar Image

Walking Dead OSX Mouse Lag

posted by joem569 on - last edited - Viewed by 2.8K users

I've been playing through the Walking Dead game, and I'm most of the way through episode 2. I am playing on a 15" Macbook Pro with an i5, 8gb of ram with an Nvidia GT 330M gpu, 256MB vram. The graphics in the game look fine, my problem is with a lagging mouse. The game doesn't lag, it's just the mouse cursor. I'm using the trackpad on the MacBook, and I've also used a usb mouse, both still lag. I tried looking at the settings menus, but there doesn't seem to be anything there that can help. I've done a quick search on the forums here, and haven't found too much about this happening to anyone else. My computer usually runs much more graphics-intense games than this with no problem, it's just this game. It's getting annoying, especially with the time-sensitive parts. Any suggestion?

18 Comments - Linear Discussion: Classic Style
  • Guys, I also just registered to post here, but in my case I might have the solution for you. At least it worked for me

    Damn, this game is so weird... I tried the same trick to get rid of another bug Im experiencing (object text not readable - text glitch), which is turning full-screen off and on.
    It didnt work, but I tried disabling full-screen, than clicked somewhere on my desktop, and re-enabled full-screen. Tadaa, the black mouse cursor from the OS disappears.

    I hope it works for you too, Im using a Mac 15inch newest OS X, nvidia gt 650m, intel 7.

  • I use an apple magic mouse for playing the game. The mouse sometimes seems laggy in the game, but for the most part, it works fine.

  • Try adjusting the screen resolution.

    I had the same problem on my imac and adjusted the screen resolution to match the resolution of the imac screen (the game default resolution was far smaller than my imacs).
    Once I adjusted the resolution didn't have any problems at all. Hope it works for you

  • Well, just having the same issue here.

    I'm playing in a Macbook Air mid 2011 and the game runs pretty well, but in some screens the mouse is laggy as hell.

    I tried lowering the resolution, the details... but it was the same. Surprisingly, going out of full screen mode the mouse stopped being laggy and started working properly.

    I hope you can fix this, but in the meantime I guess I'll stick to play in windowed mode.

  • Virtually unplayable on my 15" MBP (Mountain Lion, 2 years old top-of-the-line spec with quad-i7, 8 GB, Radeon HD 6750M 1 GB).

    Sometimes (!) it shows the system mouse cursor and the game cursor. I am playing in fullscreen at native resolution

  • @Wuddel said: Virtually unplayable on my 15" MBP (Mountain Lion, 2 years old top-of-the-line spec with quad-i7, 8 GB, Radeon HD 6750M 1 GB).

    Sometimes (!) it shows the system mouse cursor and the game cursor. I am playing in fullscreen at native resolution

    i can play with my Macbook Air, so you shouldn't have any problem with your specs, I think.

    Try not playing in full screen and see how it goes.

  • I'm running the game on a 2009 MBP with Snow leopard. When I originally installed the game I was convinced it wouldn't work because the graphics were all wonky (choppy screen with weird colors and I honestly couldn't make out ANYTHING). But I could hear the flies buzzing and could hear my mouse moving over the menu so after playing around with settings I found out that just by running toggling out of full screen and back into it the graphics reset and I could play the game normally...well except for the mouse issues you guys are talking about.

    BUT I just found somewhat of a SOLUTION. So the track pad was rough, a USB mouse made it slightly better (maybe), but it still made fights and critical moments very difficult. I found that just by toggling into the partial screen (command+F), i.e. NOT playing in full screen mode, gave me smooth complete control over the mouse. So I've been playing the game mostly in full screen, but when things go down I just toggle to partial screen and do my thing.

    Love the game - obviously there's some driver/compatibility issues, but this at least lets me play it without the massive frustration of getting my face eaten off while I'm frantically trying to get the mouse to respond.

    Hope that helps!

  • iMac, Snow Leopard, Core duo and playing with a Wacom Bamboo.

    The very same problem. Cursor is sluggish and keeps slipping as if on ice. Makes the game awfully frustrating, perhaps unplayable.

  • I had the same issue. I bought an IOGear bluetooth dongle and used it with a USB extension base

    Works FLAWLESSLY. Even during intense gaming when both the Keyboard and mouse would get so laggy it was impossible to play. It even works better than it did during normal use when I didnt have the display plugged in. Amazing results.

    Extension: http://www.amazon.com/gp/product/B001K9BFB8/ref=as_li_ss_tl?ie=UTF8&camp=1789&cr eative=390957&creativeASIN=B001K9BFB8&linkCode=as2&tag=sharaw-20

    Bluetooth Dongle: http://www.amazon.com/gp/product/B0018O9JIG/ref=as_li_ss_tl?ie=UTF8&camp=1789&cr eative=390957&creativeASIN=B0018O9JIG&linkCode=as2&tag=sharaw-20

    One thing to check, OSX directions sucked, so do this.

    1. Leave your bluetooth on, with all devices still configured/connected
    2. Option Click the bluetooth icon on your menu bar
    3. Write down the 'Address' listed. This is the address of your internal Bluetooth
    4. Plug in the Extension and then the Dongle.
    5. Wait a couple seconds
    6. Option click the bluetooth icon again
    7. Make sure a different address is shown. If so, you are now transmitting/recieving from the dongle and not the macbook.
    8. I plugged the extension into my Thunderbolt display and now I can just unplug my macbook and go. All peripherals will still work as it autoswitches back to the internal bluetooth once disconnected.

    Hope this helps

  • Hi,

    Did you find a solution to fix this problem?

    Thank you Regards Frederic

Add Comment