User Avatar Image

TWD crash on connecting

posted by halldorr on - last edited - Viewed by 2.9K users

Picked up a copy of TWD for my wife on Steam as I loved the game but she just can't play the damn thing. We have identical computers as far as hardware goes and it ran just fine for me.

Here are the things we've pulled from the forums and tried so far:

1) Played with compatibility sittings, tried them all but no luck
2) Set run as administrator, no luck, set to all users, no luck
3) Tried replacing a DLL here and there as suggested, no luck
4) We don't have controllers but we pulled all USB stuff one by one, no luck
5) Disable internet connection - this appeared to work

Is there a fix to this? I'd like her to be able to play as the game intended and have the Steam sync work properly for her without having to always disabling her internet connection.

We're both on Windows 7 64bit and we connect tot he web through a home router. Seems odd that it would crash on connecting but that is where we seem to have an issue every time.

151 Comments - Linear Discussion: Classic Style
  • Installed both drivers and it still didn't change anything.

    Going for SP1 and update windows.

  • Just got SP1 installed. Windows version is just like yours yet issue persists.... Uffff! That starts to annoy me...

  • User Avatar Image
    DjNDB Moderator

    I am running out of ideas.

    Best you can try next is the XP VM, i guess.

    I could also take a look at a Wireshark log of a crashed start.

  • Thing is, it won't help me if it'll work on a VMWare either XP or W7 ... I am not intending to play the game on a virtual machine.

    I wonder what actually causes this crash on my system. Is it related to hardware? Software? I know it's poking in the dark but i am out of ideas as well. I will try XP on a VMWare but it's not a solution - More of a test =( where results lead nowhere any ways.

    About Wireshark i can open it in a sec. Will post with a link i guess

  • User Avatar Image
    DjNDB Moderator

    Yeah, i meant the VM as a test as well. Would be strange if it crashed there as well.

    It's probably best if you do the wireshark log during a clean boot, to minimize other network traffic.

    Booting clean in Windows Vista / 7:
    1. Click Start --> Type msconfig --> Press Enter
    2. On the General tab, choose Selective Startup
    3. Uncheck Load Startup Items
    4. Select the Services tab
    5. Check Hide all Microsoft services
    6. Click Disable all
    7. If running the game on Steam, re-check the "Steam Client Service"
    8. Click on OK
    9. Click Restart.
    10. After reboot, run the game to see if it works.

    After performing the necessary steps, restore your settings by doing the following:

    1. Click Start --> Type msconfig --> Press Enter
    2. On the General tab, choose Normal Startup
    3. Click Ok
    4. Click Yes, when asked to restart your computer

  • I have noticed a very odd thing. Whenever i fresh install Wireshark on my PC it works fine and finds all network interfaces from which i can capture packets. However after i run Walking Dead, for some reason Wireshark no longer recognize any interface it can capture from and i need to re-install the program entirely for it to start working (A reboot to the system doesn't change anything)

  • User Avatar Image
    DjNDB Moderator

    That's strange indeed.

    Did you have Wireshark or WinPcap installed already the first time TWD crashed on this fresh installation?
    Does Wireshark also work again if you just reinstall WinPcap? That might narrow the problem down a bit.

  • It happens after a reboot (Cannot confirm yet if related to running the game or not. Gonna do this test now after post) and has nothing to do with WinPcap as re-installing it didn't help.
    [Link removed]
    I started the game at entry 290 till 340+

  • Update -

    The interfaces vanishing on Wireshark had nothing to do with the game. As soon as i rebooted and started Wireshark it gave me a pop up saying "NPF" driver didn't load and that's what were causing the issue.

  • User Avatar Image
    DjNDB Moderator

    I see some steam traffic in the data, a lot of UPNP stuff (SSDP) and unknown UDP Traffic.

    It DNS resolves www.telltalegames.com just before the end, but doesn't connect. Does that happen before or after the crash?

    As a last resort you could try adding www.telltalegames.com to the HOSTS file together with the other entries. Be aware that you won't be able to connect to this site as long as it's in there.

    You can also try what happens if you start Steam in Offline mode.

Add Comment