User Avatar Image

Glitch on episode 2?

posted by Rocky89 on - last edited - Viewed by 732 users

A few days ago, I played the game right through, and when I got to episode 2, I lost the fight with the Dilophosaurus the first time, and I died, thus after the fight I got Billy's "Oscar, thank God. I thought I was a goner."

But today I played episode 2 again from the start, this time I was perfect in the fight, and I still got that same response. I should have gotten his: "Hey, what did you do that for? I was winning." response.

Any reason why that happened, or do I have to uninstall the game or something because it remembers my loss?

4 Comments - Linear Discussion: Classic Style
  • Its not a glitch, it's just the default thing that he says! At least I think it is. Need Verification but I think that's the only thing he says.

  • @Jurassic#2 said: Its not a glitch, it's just the default thing that he says! At least I think it is. Need Verification but I think that's the only thing he says.

    That's odd, cause I've seen on other walkthroughs he says the other line if all goes right, so I don't see why this would be any different.

  • User Avatar Image
    MarkDarin Telltale Staff

    You're right, you should have got his "Hey, what did you do that for? I was winning." response if you had a perfect run through the fight. Not sure why it glitched. Are you sure it was a perfect run and not just a gold rating?

  • @MarkDarin said: You're right, you should have got his "Hey, what did you do that for? I was winning." response if you had a perfect run through the fight. Not sure why it glitched. Are you sure it was a perfect run and not just a gold rating?

    At first I didn't, and I think I died. But I did go back after the game to try again, this time I got gold with no mistakes, and I still got that response.

    Any ideas?

Add Comment