User Avatar Image

TWD storage device lost glitch

posted by Scumbag Lee on - last edited - Viewed by 2.1K users

So I just bought TWD: 400 days a few hours ago(on XBOX) and when I got to russels story I was at the gas station part and it stopped and said storage device lost. And every time I have to rewind the whole mission and when I get back to that part it says it again.
All my saves are fine but I can't continue the story. Nothing is wrong with my hard drive and none of the saves are corrupt.
HELP please
And it's not my one save. All of them do it. Tried deleting and redownloading the game too

7 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    MattP Bloggers

    We are looking into this issue and trying to reproduce it. If you have anymore information that may help us to do so, please let me know me. We are sorry for the inconvenience.

  • It's fine. Thanks for the reply. I have heard multiple people say they have had the problem. All my saves seem to do it around the same gas station part in russels story. Don't really have much information other then that.
    Thanks for the help though. Let me know if you find a fix please. Can't wait to play the rest.

  • @MattP said: We are looking into this issue and trying to reproduce it. If you have anymore information that may help us to do so, please let me know me. We are sorry for the inconvenience.



    Well now that I looked into this ALL DAY. It seems this has been an ongoing problem for months. Not to sound rude but I just want to play what was my favorite game. It's really turning me away from this game. Please DO SOMETHING about it.

  • @Scumbag Lee said: Well now that I looked into this ALL DAY. It seems this has been an ongoing problem for months. Not to sound rude but I just want to play what was my favorite game. It's really turning me away from this game. Please DO SOMETHING about it.



    These problems have been present since day one buddy, welcome to the club.

  • I just noticed it today as well. Funny thing is it worked fine for me yesterday, I was able to play through without any problems. I tried it on my other save and I was just on the last storyline which was Bonnie's and then it popped up right after she fell down the hill.

    At first I thought it was my X-Box 360 but after seeing this, I am seeing that it is not just me.

    I wonder if perhaps it has something to do with the order you play it in? On my first savefile playthrough, I played them in chronological order: Vince, Wyatt, Russel, Bonnie, and Shel. On this new one, I played it in this order: Russel, Shel, Wyatt, Vince, and Bonnie.

    I'm testing it right now with a copy of my first playthrough and see what happens.

    EDIT

    Well I tried it out. It did the same thing no matter what order I did it in. After I finished Shel's story, it popped right back up again. Hope this gets fixed. I was really enjoying this game series and was thinking about replaying through everything again

  • Reposting to a more current forum in the hopes that Telltale won't ignore it.

    I also have this recurring problem. I wanted to get three different saves completed before 400 days came out (already had the 1st two done), and on the 3rd save, I made it all the way through to The Gauntlet chapter of episode 5, when it popped up with the storage device removed message and crashed.

    I gave in and downloaded 400 days anyway and played it continuing on from my 1st save, and worked fine until the 4th character's epilogue (Bonnie's in my case), when it popped up with the same message again. Based on some of the suggestions on the related threads on here, I tried moving my save to cloud storage, which did nothing, and then I deleted off the 3rd save I had. Once I did this, it was temporarily fixed but I only got halfway through the 5th character's epilogue (Russell for me) before it popped up again.

    Telltale, a fix would be mightily appreciated.

Add Comment