User Avatar Image

Possible SBCG4AP Bug: Can't progress in Homsar Reservation

posted by Galbrush Sheepgood on - last edited - Viewed by 425 users

(Not sure how to add spoiler text to my message, so know this bug description contains some spoilers for in game activity.)

I'm at the point in the game where I dropped all three necessary items into the rock formation. I put in the tuning fork and the three ring binder right away. I found these items with the metal detecTOR long before I entered the reservation and talked to Homsar.

Later I solved the puzzle with Bubs in order to get the pottery shard. I dropped it in, talked to Homsar, and he still speaks in half jibberish, half english. So I can't get into the cave and progress any further.

According to the walkthrough I have done exactly what I needed to do in order to progress. The fact I'm stuck in limbo makes me think I've encountered a bug. Or did I miss puzzle a step somewhere? Maybe my save point is corrupted?

If this is a bug, could it have been triggered by the order in which I tried to solve the puzzle? (dropping in the 2 items found with the detecTOR immediately, then later giving the pretendix to Bubs, getting the pottery shard and dropping it in.)

Sidenote: After reloading my save point right before I talk to Homsar, I get the dreaded eye dispearring bug on him. This is the first and only time I've witnessed this bug in Episode 2. (my DirectX is nice and updated.)

6 Comments - Linear Discussion: Classic Style
Add Comment