Menu
User Avatar Image

S&M 301 crash woes (Mac)

posted by light_rises on - last edited - Viewed by 2.3K users

This problem's a bit different than the other crash thread, so I hope making this one is okay ...

Around the middle of the title sequence -- and always in the same place -- the game crashes. I've launched it three times, changing the graphics quality and resolution to see if I could break past it. Nothing doing. :(

I have a feeling a redownload/install will be in order. In which case ... how do I keep my saves? Is that done automatically, or do I have to do something with them before I reinstall?

FWIW, I've attached the last crash report. If you guys need anything else, just let me know.

Thanks in advance!

75 Comments - Linear Discussion: Classic Style
  • Update for you all, things are being looked at. They have been being looked at, mind you, but it looks like we are really close to something.

  • Thank you, Will, for letting us know that something is happening. More details are better, of course, but I understand. :-)

  • I'm happy to report that after the first hour of play, Ep.2 has solved the crash problems for me seen in Ep.1. Good news!
    I'm running version 1.0.0.25, I'll DL the new one now.

  • I moved my message into a slightly more applicable thread, but I honestly think the crash issue is directly related to the performance issues we were seeing. If 302 seems to be shaping up with issues solved and such, then we will try to quickly turn around and fix 301. I can't promise any sort of time frame unfortunately, but it's pretty darn high on my priority list.

  • Oh heck yea! 1.0.1.25 is MUCH faster. Good work guys!

  • @Will said: I moved my message into a slightly more applicable thread, but I honestly think the crash issue is directly related to the performance issues we were seeing. If 302 seems to be shaping up with issues solved and such, then we will try to quickly turn around and fix 301. I can't promise any sort of time frame unfortunately, but it's pretty darn high on my priority list.

    Is fixing Mac ToMI on your list too?
    Right now i have a whole season of unplayable Mac ToMI...

  • Things will likely be one step at a time for a bit I'm afraid. Rebuilding is no small task and it has to be inserted into an already swamped schedule. Also, I'm not entirely sure Monkey has the same problem, but I'll certainly look into it.

  • I also had the same problem on my standard MacBook, but on the iMac it worked without any flaws...

  • 302 is same same.
    For me, trouble starts just when the projector starts running (different to my memory issue suggestion this points somewhere else, if you combine with the situation in 301. beam -> lighting -> T&L issue?) during the intro. The first gameplay scene here is pretty much as bad as the first scene in 301, and again, after a restart it is perfectly smooth. I experience no difference between 301 (10.0.0.25) and 302 (10.0.0.25) whatsoever. I have not tried reducing graphics quality/resolution, but this didn't help with 301 either.
    I really hope you guys find a solution soon! thanks for letting us know that you are working on it.

    edit: just saw in the 302-thread that there already is a second version of 302 available. i hope that mine is the first one and will try downloading again (version no in the file name or on the download page would be great)

  • Well, for me the intro/credit sequence played completely without a crash in 302, so I suspect whatever bug was making the 301 version crash during the intro has been fixed. I am seeing graphic stuttering, though, so I'll likely re-download 302 tonight to make sure I have the latest build.

    Thanks!

This discussion has been closed.