Menu
User Avatar Image

OS X 10.9 Instant Crash [Fixed in update]

posted by wernerdev on - last edited by DjNDB - Viewed by 36.5K users

I am running OS X 10.9 GM, but The Walking Dead instantly crashes when trying to start it. It seems it has to do with the Code Signature of the game: Exception Type: EXC_CRASH (Code Signature Invalid)

Is this known? Working in a fix? Because 10.9 is going live somewhere near the end of this month...

44 Comments
  • It doesn't work for me... In the terminal, I read: TheWalkingDead.app: bundle format unrecognized, invalid, or unsuitable In subcomponent: /Applications/TheWalkingDead.app/Contents/Frameworks/SDL.framework

    • User Avatar Image
      DjNDB Moderator

      I don't know what causes these error messages. It worked for me the way I described it. I am not a Mac expert at all, but hopefully someone will find out what causes that.

  • This is just not acceptable. If they (Telltalegames) are developers, then they have had access to 10.9 for over six months. That they even use the "Sudden" and "Unexpected" launch of 10.9 as an excuse is LAME. As a developer myself, we get the OS many months before the actual release. To add insult to injury developers are also warned before the launch of an OS to make sure they have their software up to date. I have updated my OS and I am current. The developer should do so as well.

  • At least they are on it.

    Thanks DjNDB of your efforts

  • When will TTG get the update for OSX 10.9?

  • User Avatar Image
    MattP Telltale Staff

    We have just released an update that will resolve this issue, but you will need to install the latest version of the game. To do this, uninstall the current version of The Walking Dead that is installed on your computer. Then login to your Telltale account, select the drop-down arrow next to your avatar, select 'My Games' and download the Mac installation file (version 4). Once re-mstalled, you should no longer experience an issue on OS X 10.9.

  • I just got this... :

    Process: WalkingDead101 [2025] Path: /Applications/TheWalkingDead.app/Contents/MacOS/WalkingDead101 Identifier: com.telltalegames.WalkingDead101 Version: ??? Code Type: X86 (Native) Parent Process: launchd [147] Responsible: WalkingDead101 [2025] User ID: 501

    Date/Time: 2014-01-05 15:18:54.152 +0530 OS Version: Mac OS X 10.9.1 (13B42) Report Version: 11 Anonymous UUID: C9C49364-CD4C-4CA8-6ABC-B5C7BEBB9006

    Sleep/Wake UUID: AEC96C23-41C4-451B-96F4-4680A932E0A2

    Crashed Thread: 0

    Exception Type: EXC_CRASH (Code Signature Invalid) Exception Codes: 0x0000000000000000, 0x0000000000000000

    VM Regions Near 0 (cr2): --> VM_ALLOCATE 0000000000000000-0000000000001000 [ 4K] ---/--- SM=NUL
    mapped file 0000000000001000-000000000056b000 [ 5544K] r-x/rwx SM=COW /Applications/TheWalkingDead.app/Contents/MacOS/WalkingDead101

    Thread 0 Crashed: 0 dyld 0x8fe4f030 _dyld_start + 0

    Thread 0 crashed with X86 Thread State (32-bit): eax: 0x00000000 ebx: 0x00000000 ecx: 0x00000000 edx: 0x00000000 edi: 0x00000000 esi: 0x00000000 ebp: 0x00000000 esp: 0xbffffd48 ss: 0x00000023 efl: 0x00000200 eip: 0x8fe4f030 cs: 0x0000001b ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x00000000 cr2: 0x00000000

    Logical CPU: 0 Error Code: 0x00000000 Trap Number: 0

    Binary Images: 0x8fe4e000 - 0x8fe80417 dyld (???) <4B280BB1-55F8-313F-86A6-8ADD644ED69E> /usr/lib/dyld

    External Modification Summary: Calls made by other processes targeting this process: task_for_pid: 0 thread_create: 0 thread_set_state: 0 Calls made by this process: task_for_pid: 0 thread_create: 0 thread_set_state: 0 Calls made by all processes on this machine: task_for_pid: 5092 thread_create: 0 thread_set_state: 0

    VM Region Summary: ReadOnly portion of Libraries: Total=280K resident=212K(76%) swapped_out_or_unallocated=68K(24%) Writable regions: Total=8508K written=0K(0%) resident=12K(0%) swapped_out=0K(0%) unallocated=8496K(100%)

    REGION TYPE VIRTUAL =========== ======= Stack 64.0M VM_ALLOCATE 12K VM_ALLOCATE (reserved) 148K reserved VM address space (unallocated) __DATA 168K __LINKEDIT 76K __TEXT 204K mapped file 274.8M shared memory 4K =========== ======= TOTAL 339.4M TOTAL, minus reserved VM space 339.2M

    Model: MacBookAir5,1, BootROM MBA51.00EF.B02, 2 processors, Intel Core i5, 1.7 GHz, 4 GB, SMC 2.4f19 Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 1024 MB Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3230554638454455302D474E2D4620 Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3230554638454455302D474E2D4620 AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE9), Broadcom BCM43xx 1.0 (5.106.98.100.22) Bluetooth: Version 4.2.0f6 12982, 3 services, 15 devices, 1 incoming serial ports Network Service: Wi-Fi, AirPort, en0 Serial ATA Device: APPLE SSD TS128E, 121.33 GB USB Device: USB Optical Mouse USB Device: Hub USB Device: FaceTime HD Camera (Built-in) USB Device: Hub USB Device: Hub USB Device: BRCM20702 Hub USB Device: Bluetooth USB Host Controller USB Device: Apple Internal Keyboard / Trackpad Thunderbolt Bus: MacBook Air, Apple Inc., 23.4

    • User Avatar Image
      DjNDB Moderator

      When did you download it? You need to download the latest version from the my games section.

      You get to the "My Games" section, by pressing the Alt text icon at the top of the page and selecting "My Games".

  • can you please make a youtube video about the procedure of the installation...please that would be some great help..i hope this message reaches you...thanks i tried doing it every possible way but i couldnt...please help

  • /Applications/TheWalkingDead.app: replacing existing signature /Applications/TheWalkingDead.app: unsealed contents present in the bundle root

    ^^KEEPS ON COMING OUT :'(

  • TheWalkingDead.app: No such file or directory

    ^what To do if this thing comes out?

    • User Avatar Image
      TelltaleMike Telltale Staff

      Can you please clarify if you have tried uninstalling the current version of the game, and downloading the new installer from our website, then reinstalling the game? Your issue should be resolved by doing this.

      If you still experience the issue after downloading the new installer, please read this Sticky on how to run our Support Tool, and follow the steps to run the tool, and reply here with the download link copied and pasted into a reply. You can find the Sticky here:

      http://www.telltalegames.com/community/discussion/44150/twd-support-tool-for-information-gathering

      After receiving the information from your support tool, I will be able to assist you further.

This discussion has been closed.