Menu
User Avatar Image

Error when trying to run game.

posted by Slater on - last edited - Viewed by 697 users

Every time I try to run Puzzle agent I get a message that says "The application failed to initialize properly (0xc0150002). Click on OK to terminate this application." Is there anyway to fix this? It would kind of suck if I just spent money on something I can't even play :/

9 Comments - Linear Discussion: Classic Style
  • Does the suggestion towards the end of this thread help?

    http://www.telltalegames.com/forums/showthread.php?t=17886

  • Well it fixed my first problem. Now I can start it up just fine and sign into my profile, but when i try running the game it says it can't run direct3d or something's wrong with my video card/driver. How can I tell what kind of video card I have? I'm trying to run this on my X61 Thinkpad laptop (it's the only computer I have)

  • User Avatar Image
    DjNDB Moderator

    Make sure your display color depth is set to 32 bit.

    If that doesn't fix it please post a dxdiag log.

    dxdiag
    Windows XP: Go to your start menu and click on run. Type in "dxdiag" and hit enter
    Windows Vista / 7: Press the windows key on your keyboard or click on the start menu. Type in "dxdiag" and hit enter.

    Now click on the button that says "save all information".
    It will prompt you to save a file. Save it where you can find it.

    Then zip the file and attach it to a reply in this Thread.

  • Hi there, I'm currently experiencing the same problem running the program. I've already attached the dxdiag in a zip file. If you can help my situation out, that would be wonderful as I'm trying to review your product. :)

    Thanks!

  • User Avatar Image
    DjNDB Moderator

    @Sparking Dawn 117 said: Hi there, I'm currently experiencing the same problem running the program. I've already attached the dxdiag in a zip file. If you can help my situation out, that would be wonderful as I'm trying to review your product. :)

    Which of the above error messages do you get?

    Anyway, you could start by updating your drivers:

    Card name: Radeon X1900 Series
    Mini VDD Date: 1/14/2009 02:14:01, 3455488 bytes

    Description: SB X-Fi Audio [BC00]
    Date and Size: 6/18/2007 04:01:28, 514560 bytes

    Try installing the latest Radeon X1900 Driver and X-FI XtremeMusic Driver.

    Also run the DirectX updater.

  • I get the (0xc0150002) error.

    Thanks for the suggestions, I'll try both on for size.

  • User Avatar Image
    DjNDB Moderator

    @Sparking Dawn 117 said: I get the (0xc0150002) error.

    In that case you should also try the suggestion from above to install the Microsoft Visual C++ 2008 SP1 Redistributable Package.

  • Radeon X1900 Driver, Direct X Updater, and Microsoft Visual C++ 2008 SP1 Redistributable Package have been successfully downloaded but Puzzle Agent still doesn't seem to play at all. I tried removing it and then adding it back in, but nothing. Maybe there's something else?

    I'm using a Windows XP by the way. Could I assist you with any other information?

  • User Avatar Image
    DjNDB Moderator

    @Sparking Dawn 117 said: Radeon X1900 Driver, Direct X Updater, and Microsoft Visual C++ 2008 SP1 Redistributable Package have been successfully downloaded but Puzzle Agent still doesn't seem to play at all. I tried removing it and then adding it back in, but nothing. Maybe there's something else?

    Just to be clear, because you say "downloaded": Did you install them too?

    Besides that you can try to run dependencywalker/ and load the Grickle101.exe. It might show some useful error messages like missing files.

This discussion has been closed.