User Avatar Image

Poker Night at the Inventory - Mac Crash Info

posted by DesertMaus on - last edited - Viewed by 9.1K users

[UPDATE 3-27-2013]
Steam just posted a client update, now running steam client:
Steam API v012, Updated 3-25-2013, Package Version 1364340477 / 1364340477

This has not resolved the issue, so this leaves me to believe it was the Apple/Mac OS-X update from
10.8.2 --> 10.8.3 released March 14th 2013...

@Mr Fist said: New post comin' up.

"the game suddenly quits before a new hand is dealt. I've tried doing many graphic configurations as I could but nothing works."


Looks like the latest Steam OR maybe OS-X update did in fact do something.

I am experiencing the same exact problem. Happens in the same spot as this post, just after your hand is dealt and the host says, "Tonights steaks will be ten-thousand dollars" within a few milliseconds, BAM closes out with an Apple debug report. However, if you hit SPACEBAR just before that is said, I can cruise around all the goodies, change tables, card deck styles etc, but when clicking back, just as the music is about to kick in BAM.

1) Mac OS-X 10.8.3 Updated 3-16-2013
2) Steam API v012, Updated 3-15-2013, Package Version 1363394288 / 13633954288

* Seems to be after Apple OS-X 10.8.3 update or Steam Update
* Ran Steam Cache checker, returned without error
* Completely removed from Steam Library and double checked local file system, all files gone - Then re-downloaded
* Tried all video resolutions including full screen and windowed
* Changed sound output settings system-wide to use external headphones or bluetooth headphones.

Crash Report:
If I look at the crash report directly or open 'Console' to load a ReportedCrash. there is a lot of debug information.

Crashed Thread: 0 MainThrd Dispatch queue:

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

VM Regions Near 0:
__PAGEZERO 0000000000000000-0000000000001000 [ 4K] ---/--- SM=NUL /Users/USER/Library/Application Support/Steam/*/

__TEXT 0000000000001000-0000000000002000 [ 4K] r-x/rwx SM=COW /Users/USER/Library/Application Support/Steam/*/

Thread 0 Crashed:: MainThrd Dispatch queue:

Followed by ~370 lines of debug information. I looked for core files to strings against, but not sure how Apple hacked the Darwin kernel to not allow for `core` file dumps but rather some Apple proprietary binary crash log.

I know it's an older game but it's so awesome. My wife and I love to play together, it's a nice stress reliever.

If anyone at TellTale Games wants my output file in full or whatever is needed, I would be more than happy to send along:)

Thanks for any help!

47 Comments - Linear Discussion: Classic Style
This discussion has been closed.