Menu
User Avatar Image

Unable to play Back to the Future on ipad

posted by tinydioramas on - Viewed by 873 users

Hi, I tried to search for my problem, but couldn't find anything exact. Sorry if I've overlooked something. I am having issues with opening Back to the Future on my ipad. I was playing the first chapter with no issue and, before finishing the chapter, I purchased the multi-pack. When it tried to download it gave an error. I want to say it was a generic download error or internet connection error? It was gone quickly and I didn't completely catch it before the app shut down back to the home screen. Now, when attempting to open the game, it shows a brief flash of the loading screen, goes black for a second or two, and goes back to the home screen. The game is still running, as it can be seen in the current app screen (whatever it is called), stuck at the loading screen with Marty looking at a floating delorean. Selecting it from that screen results in the same: black for a second and back to the home screen. I have tried shutting off the ipad and waiting more than 3 minutes as recommended to clear the cache. I have turned the wifi on and back again. I have uninstalled and reinstalled from the cloud. I still cannot get the game to open properly at all. Any help would be appreciated.

7 Comments
  • User Avatar Image
    TelltaleMike Telltale Staff

    I apologize for the inconvenience. I recommend deleting the game application one more time, then restarting your device. Then re-download the game application, and shut your device off again after the download completes (Do not start the game before turning off your device.) Then after restarting your device, make sure you are connected to a WiFi network, and then start the app. You should now be able to get into the game successfully. If you are still experiencing an issue, can you please clarify what generation iPad you are currently using, and what iOS version you are currently running on it?

Add Comment